No announcement yet.

RENDER ELEMENTS Enable filtering check does not work

  • Filter
  • Time
  • Show
Clear All
new posts

  • RENDER ELEMENTS Enable filtering check does not work

    Enable filtering check does not work.

    The system always applies filtering. In certain elements this implies bad coding of the channel, for example if we want to differentiate materials in the intersection areas we obtain the mixture of two materials (which does not coincide with the code of any real material). If the check worked, it would be resolved.

    Attached Files

  • MarcHydragrafix

    Thanks for the quick reply. With FStormMaterialIdChannel we have the same problem. The Enable filtering check does nothing (I suppose that as an unbiased engine works it is impossible to correct this).

    We can actually see the problem as two different problems.
    Problem 1: At the intersections between objects there is a mix between the channels of the two objects, therefore many channels give values ‚Äč‚Äčthat are non-existent (Materials, Z, Coordinates, etc.)
    Problem 2: For isolated objects, when the alpha is pre-multiplied, the RGB value is also wrong. In my image you can see how the FrameBuffer stores a different R (red) for the pixels with alpha = 0 and alpha> 0, therefore we cannot know the material of the pixels with AA.
    Actually a solution would be to store (or give the option) the Element channel with alpha (RGBA), in this way in the example we could have the same R value for the whole object, and its alpha separately, and we could identify the pixels with alpha with its appropriate material.
    Fixing problem 2 the 1 would not be necessary since we can separate the objects. Many thanks in advance.

    Leave a comment:

  • Karba
    This is a bit difficult question. some pixels contain mix of different surfaces/materials and other matter. If you want to have an accurate masks of each material, you have to use FStormMaterialIdChannel render element.

    Leave a comment: