Announcement

Collapse
No announcement yet.

Environment is still casting a shadow

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Tok Tok
    started a topic Environment is still casting a shadow

    Environment is still casting a shadow

    Hello Karba,

    I do a lot of product visuals and therefore I use functions like exclude/include, visible to camera, cast shadow etc. a lot. I noticed there have been improvements in that part of Fstorm. Light don't cast shadows over each other anymore even though "Visible" is unchecked, and some other stuff so thanks for that! There is however, still an issue when I turn on the environment light, this still casts a shadow from Fstorm lights and planes with a light material. Can this be fixed?

    Also, I would like to request again to copy/move some settings from the "Fstorm object settings" menu to the Fstorm lights themselves. Also better naming like "visible to reflections" together with "visible to camera" will help it be a bit more clear, because sometimes it can be confusing what does what.

    And I have another request, can there please be a picker icon next to the exclude/include button so that you don't have to search for the object names when you want to exclude something. Would be awsome!

    Thanks.

  • Tok Tok
    replied
    I'm not so sure to be honest. Corona does this in some way, I think by removing the object altogether from the scene but still emitting rays from that position. Please take a look at these screenshots. They have a feature called "occlude other lights" which I almost always turn on to avoid shadows on my ground plane. I far as I know Fstorm handles this well by turning off the visibility but apparently doesn't work with Environment lighting.
    This has the "occlude other lights" off This has the "occlude other lights" on

    Leave a comment:


  • Karba
    replied
    There is no way to avoid this situation. For proper emission light source has to affect GI. but if it doesn't emmit anything, it just cast GI shafows.

    Leave a comment:

Working...
X